2026/03/05 Cloud server upgrades

Scheduled for Mar 5, 20:00 UTC  -  Mar 6, 03:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 27, 2026 - 10:29 UTC

Scheduled

We will be performing upgrades on our cloud servers on March 5th, 2026 from 20:00 UTC til March 6th 03:00 UTC. During this time all services (wikis, images, Phorge, etc.) will be completely unavailable. We apologize for any inconvenience this may cause.
Posted Mar 05, 2026 - 20:00 UTC
This scheduled maintenance affects: Services (Miraheze, Phorge, Matomo, Icinga, Miraheze Test Wiki) and Infrastructure (MediaWiki, Cache Proxies, Databases, DNS, File Storage).